Notice: Undefined offset: 0 in /home/templaza/public_html/plugins/system/tz_guard/tz_guard/browser_detection.php on line 361

Deprecated: strpos(): Non-string needles will be interpreted as strings in the future. Use an explicit chr() call to preserve the current behavior in /home/templaza/public_html/plugins/system/tz_guard/tz_guard/browser_detection.php on line 618
Safer PHP Version for Joomla 3 – Highly Recomend - TemPlaza | Blog
TemPlaza

TemPlaza, the website built and improved by TemPlaza., JSC. We supply templates and other qualified applications on Joomla and WordPress.

Email: support@templaza.com

Safer PHP Version for Joomla 3 – Highly Recomend

Safer PHP Version for Joomla 3 – Highly Recomend

Some days ago, Joomla 3.4.7 has been released and it is specifically targeted people on old, out-of-date PHP versions. So, the question now is which version is the best one?

In this article, we will give you some recommendations for this problem to keep your site secure.

1. Recommended PHP versions

These are the recommended minimum versions for Joomla 3:

  • 5.4.45 or newer
  • 5.5.29 or newer
  • 5.6.13 or newer

For example, if you're using PHP 5.4 series, be sure your version is 5.4.45 or newer to keep your site protected.

2. Check your PHP version

Now, you need to check the PHP version in your site. In the Admin Panel of your site, please go to System > System Information then you can see the PHP Version.

In this example, it’s 5.4.19 which is out-of-date so we need to update to PHP 5.4.45 or higher.

3. Switch PHP version on shared hosting

If the PHP version is not good, it should be changed into a good one. This step depends on your hosting provider.

I will take SiteGround as an example. Let’s navigate to PHP Version Manager

Now, please choose a newer version for your site from the list, and click the "Save" button:

After that, please check the result to make sure that it is success.

If you don't find a way to move to a safer PHP version using cPanel, ask your hosting provider so they can do it for you.

In addition to updating your PHP version, don't forget to update Joomla in your site to the latest version to keep it completely protected.

Thanks for reading!

WordPress 4.4.1 - The Security Release
How to Configure Megamenu of Plazart Framework in ...
Comment for this post has been locked by admin.
 

Comments Comments

By accepting you will be accessing a service provided by a third-party external to https://ns2.templaza.com/

Login